7.3.5 Maintenance Releases of SecureCRT and SecureFX Now Available

New maintenance releases of SecureCRT 7.3.5 and SecureFX 7.3.5 are now available for download.

The 7.3.5 releases of SecureCRT and SecureFX include a passphrase requirement that improves security when saving passwords and other sensitive data.  SecureCRT and SecureFX require a passphrase to be created the first time version 7.3.3 and newer runs.  The passphrase will need to be entered every time SecureCRT and SecureFX starts and will be used to encrypt and decrypt sensitive data stored in the session database.

For more details, please visit:

https://www.vandyke.com/support/advisory/2015/03/index.html

You can download any of the 7.3.5 official releases from the official download page.

Find out more about the 7.3.5 releases:

Please see the history files for a complete list of changes:

We want to hear your feedback.  Send questions, requests, or bug reports to support@vandyke.com.